Opened 7 years ago

Closed 6 years ago

#725 closed defect (cant-reproduce)

The player doesn't run under Mageia Linux 2 in Mozilla Firefox 17 ESR

Reported by: Julien Gouesse Owned by:
Priority: major Milestone:
Component: programming Keywords:
Cc: Parent Tickets:

Description

The player doesn't start playing the video under Mageia Linux 2 in the web browser Mozilla Firefox 17 ESR whereas I can watch this video with VLC. I use the desktop manager KDE and then Dragon Player is used inside the web browser to play the video by default.

Subtickets

Change History (8)

comment:1 Changed 7 years ago by Emily O'Leary

Could you provide more detail on this?

Is this a locally hosted instance or one hosted on another server?
If it is hosted externally, are you running it with a server software like apache/nginx?

If you are just running the lazyserver it could be a mimetype issue where GMG isn't telling the browser what kind of file a WebM file is.

If you can view the video under Chromium then this may be the issue (as Chromium is willing to inspect the file to determine its file type).

comment:2 Changed 7 years ago by Julien Gouesse

Hi

Actually, the problem comes from Totem, I thought it Dragon Player was used by default, I was wrong. When I play a WebM file with Totem outside of the web browser, sometimes nothing works, sometimes I only hear the sound.

When I try to play the same videos under Windows with Firefox 21, it works flawlessly. I assume the problem doesn't come from the mime type.

I use this instance:
http://roaming-initiative.com/mediagoblin/

Yes it works both with Chromium and Google Chrome.

comment:3 Changed 7 years ago by Emily O'Leary

Ahhh, yes, I've had that issue before. What gstreamer plugins do you have installed?

comment:4 Changed 7 years ago by Julien Gouesse

gstreamer0.10-vp8 version 0.10.23-3 is installed. It should work. I've installed all plugins available on the official repository including the tainted ones.

comment:5 Changed 7 years ago by Emily O'Leary

Are the issues you are having with the same files failing to play or with different files? If it is with different files, is there anything different about them from what you can tell?

comment:6 Changed 7 years ago by Julien Gouesse

Actually, I tried to upload my 3GP file as is. As it failed, I converted it into MP4 with FFMPEG and tried to upload it again and it worked. The upload and the transformation were successful. I can't play any video hosted on Mediagoblin, not only mine, I tested with the videos posted by other users.

comment:7 Changed 6 years ago by Julien Gouesse

It's no longer reproducible for an unknown reason.

comment:8 Changed 6 years ago by Julien Gouesse

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.