Opened 7 years ago

Closed 4 years ago

Last modified 4 years ago

#724 closed defect (cant-reproduce)

The transformation of .3gp files always fails

Reported by: Julien Gouesse Owned by:
Priority: minor Milestone:
Component: programming Keywords:
Cc: Parent Tickets:

Description

Hi

It is possible to upload successfully a 3GP file, I get a confirmation message when it is done. However, the transformation fails, it appears in the subsection for failed additions but with no value in the fields "Reason for failure" and "Failure metadata". If you don't plan to support this format, please fill these fields.

Subtickets

Attachments (1)

bug724.png (131.3 KB) - added by Julien Gouesse 7 years ago.
screen capture showing the result of the failure

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by Julien Gouesse

Attachment: bug724.png added

screen capture showing the result of the failure

comment:1 Changed 7 years ago by Emily O'Leary

Thank you for reporting your problem.

Would you please include a stack trace and/or the console output for the server when this particular issue happens?

Then we might be able to tell exactly what's going on.

comment:2 Changed 7 years ago by Julien Gouesse

I can contact the guy who is responsible for roaming-initiative to get these logs. I'll try to post them as soon as possible.

comment:3 Changed 7 years ago by Philip Horger

@LotusEcho Sorry for the delay in getting on this. I'm the site admin for roaming-initiative.com.

In my experience, there is never a reason given when a transcoding operation fails. I've looked for the appropriate logs, but I'm not sure the failures are being logged anywhere. I have one of the fancy Celery setups where new, separate processes are spun off for transcoding jobs. I haven't been able to find where the failures are logged, or if they are at all, there is no failure information being written to psql either.

comment:4 Changed 7 years ago by Emily O'Leary

My phone can capture 3gp files so I'll try to replicate this error to see if I can debug it.

comment:5 Changed 7 years ago by Emily O'Leary

I've not been able to replicate the issue on my dev environment (which is running the 0.4.1-dev version that I see the site runs). But this version doesn't use FastCGI or a separate celery.

My guess is that there's some oddity happening in that interaction. Once I can update my test server to 0.4.1 I can give it another try.

comment:6 Changed 6 years ago by Julien Gouesse

My new smartphone captures mp4 files, I just convert them into webm files with ffmpeg. I can try to reproduce this bug if necessary but feel free to lower the priority as I have a workaround.

comment:7 Changed 6 years ago by Julien Gouesse

Priority: majorminor

comment:8 Changed 4 years ago by Ben Sturmfels

Resolution: worksforme
Status: newclosed

Hi Gouessej,

I've just downloaded a sample 3GP file and tested it on MediaGoblin v0.9.0. Upload and transcoding worked correctly. So it is likely that either the v0.8.0 (June 2015) upgrade to GStreamer 1.0 fixed the issue, or that my test file was different to yours.

I'll close this issue for now, since the GStreamer 1.0 upgrade did fix a whole lot of transcoding issues. If you still have the file though, I'd love to test it for you or hear your results from testing against v0.9.0.

Cheers,
Ben

comment:9 Changed 4 years ago by Ben Sturmfels

(For what it's worth the two videos I uploaded successfully were 3GP container format with H263 video and AMR narrow band audio, as reported by VLC.)

Note: See TracTickets for help on using tickets.