Opened 9 years ago

Closed 8 years ago

#5072 closed defect (fixed)

configure hardcoded to outdated python3

Reported by: ayleph Owned by:
Priority: major Milestone: 0.9.0
Component: programming Keywords: python, python3, configure
Cc: Parent Tickets: 5017


./configure --with-python3 fails when python3.4 is the installed version of python3.

(mediagoblin-0.8.0-dev) ~/mediagoblin $ python --version
Python 3.4.3
(mediagoblin-0.8.0-dev) ~/mediagoblin $ ./configure --with-python3
checking for python3.3... no
configure: error: in `/srv/mediagoblin/mediagoblin':
configure: error: --with-python3 given but no acceptable python3 (3.3) could be found
See `config.log' for more details

I'm going to set a milestone of 0.9.0 on here because of ticket #5017.

Attachments (1)

0001-Do-not-require-python3.3-explicitely.patch (1.1 KB ) - added by Boris Bobrov 8 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 by berkerpeksag, 9 years ago

Parent Tickets: 5017

comment:2 by Boris Bobrov, 8 years ago

Status: newreview

Attached a patch, please review.

comment:3 by berkerpeksag, 8 years ago

I'm not familiar with distributions other than Ubuntu, but it's unlikely the patch is going to break anything. So looks good to me!

comment:4 by Christopher Allan Webber, 8 years ago

Resolution: fixed
Status: reviewclosed

Merged. I think you're right. Thanks! :)

Note: See TracTickets for help on using tickets.