Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#981 closed defect (fixed)

Unhandled Exception when using LDAP plugin

Reported by: tawhuac Owned by:
Priority: critical Milestone:
Component: programming Keywords: ldap plugin
Cc: Parent Tickets:

Description

We are using the LDAP plugin for authentication. However, when we enable LDAP, after entering username and password, the site returns with

== Unhandled Exception ==
 

An unhandled exception was thrown by the application.

Pretty ugly...Proper error management and a nice error message at least would help because now we are stuck because we don't know if the config is wrong or there is a problem with mediagoblin.

Here's the config:

[plugins]
[[mediagoblin.plugins.geolocation]]
#[[mediagoblin.plugins.basic_auth]]
[[mediagoblin.media_types.image]]
[[mediagoblin.plugins.ldap]]
[[[server1]]]
LDAP_SERVER_URI = 'ldap://10.10.10.7:389'
LDAP_BIND_DN = 'cn=admin,dc=<HIDDEN>,dc=cc'
LDAP_BIND_PW = '<HIDDEN>'
LDAP_USER_DN_TEMPLATE = 'cn={username},ou=Users,dc=<HIDDEN>,dc=cc'
EMAIL_SEARCH_FIELD = 'mail'

The log file only prints:

2014-09-28 19:37:01,106 INFO    [mediagoblin.plugins.ldap.tools] Connecting to ldap://10.10.10.7:389.
2014-09-28 19:37:01,106 INFO    [mediagoblin.plugins.ldap.tools] Unbinding ldap://10.10.10.7:389.

So it seems it DOES connect to LDAP but for some reason it fails.

Using mediagoblin 0.7.1

Subtickets

Change History (4)

comment:1 Changed 7 years ago by tawhuac

Confirmed to happen on debian stable, ubuntu 14.04 and Linux Mint 17 (Qiana)

comment:2 Changed 7 years ago by tawhuac

To me it looks like it's not mediagoblin itself; could be linked to some missing python lib, or configuration issue or something like that

comment:3 Changed 6 years ago by tawhuac

Resolution: fixed
Status: newclosed

comment:4 Changed 6 years ago by tawhuac

As of

mediagoblin 0.8.0

this seems not to be an issue anymore.

But you need to provide a value for the

LDAP_START_TLS

variable in the mediagoblin_local.ini file for the ldap plugin, e.g.

LDAP_START_TLS = 'false'

.

Also, take care with the LDAP cn, so that they match.

Note: See TracTickets for help on using tickets.