Opened 7 years ago

Closed 6 years ago

#978 closed defect (fixed)

Deployment docs need updating to reflect change from paster to gunircorn

Reported by: BERGER Owned by:
Priority: major Milestone: 0.9.0
Component: documentation Keywords:
Cc: Parent Tickets: #5017

Description

mediagoblin@menelikII:/home/mediagoblin.example.org/mediagoblin$ ./lazyserver.sh --sever-name=broadcast
Using gunicorn config: paste.ini
Using ./bin/gunicorn
+ export CELERY_ALWAYS_EAGER=true
+ ./bin/gunicorn --paste paste.ini --sever-name=broadcast
usage: gunicorn [OPTIONS] [APP_MODULE]
gunicorn: error: unrecognized arguments: --sever-name=broadcast
mediagoblin@menelikII:/home/mediagoblin.example.org/mediagoblin$

I follow the deployment step by step, and this error occurs (see above)
What did I do wrong ?

Any helm possible, i really wanna have Mediagoblin running !!!!

Subtickets

Change History (8)

comment:1 Changed 7 years ago by BERGER

Sorry, I forgot to say Hello Hi Bonjour and so on ...
Please i need some help !

comment:2 Changed 7 years ago by Matt Molyneaux

Component: programmingdocumentation
Milestone: 0.8.0
Status: newaccepted
Summary: after install server's test won't work :Deployment docs need updating to reflect change from paster to gunircorn

comment:3 Changed 7 years ago by Jessica Tallon

This is a problem because gnuicorn isn't able to use different server blocks which is what the ´--server-name´ option on paste did. The docs for gnuicorn say:

At this time, using alternate server blocks is not supported. Use the command line arguments to control server configuration instead.

I see it as we have two options, we could:

  1. make the default broadcast but that would mean any development would always be exposed all the time when using gunicorn (not a great idea)
  2. We could try and catch the --server-name option and change the --bind option which overrides the settings set in the paste.ini file.

Personally I think the best all be it a bit horrible is the second option. What do people think?

comment:4 Changed 7 years ago by Christopher Allan Webber

Milestone: 0.8.00.9.0

So, we "punted" on this in 0.8.0 by making python 3 "experimental" and having things default to Python 2. But we should, by the next release, have Python 3 be a "first class citizen". As such, I'm making a bug about that which will link to this, and also mark this bug for 0.9.0.

comment:5 Changed 6 years ago by berkerpeksag

Parent Tickets: 5017

comment:6 Changed 6 years ago by ayleph

Is this still a valid issue now that Python3 Paste support is available? See #5317.

comment:7 in reply to:  6 Changed 6 years ago by Jessica Tallon

Replying to ayleph:

Is this still a valid issue now that Python3 Paste support is available? See #5317.

I think you might be right. I have opened an issue about moving back to Paste, until we do that though, this still remains an issue. It's worth noting I believe Python3 support is still "experimental" by the looks of things.

The issue is: #5410

comment:8 Changed 6 years ago by Christopher Allan Webber

Resolution: fixed
Status: acceptedclosed

Via #5419 we've discovered a resolution moving to waitress for now. So I think that closes this.

Note: See TracTickets for help on using tickets.