Opened 11 years ago

Closed 10 years ago

#806 closed defect (fixed)

on setup, kombu 3.0 conflicts with celery 3.0.24

Reported by: criticalcat Owned by:
Priority: blocker Milestone:
Component: programming Keywords:
Cc: Aleksej Parent Tickets:


Given fresh install on Trisquel 6.0 by following setup instructions here:

When running this command:

(sudo -u mediagoblin virtualenv --system-site-packages .
virtualenv .) && sudo -u mediagoblin ./bin/python develop

Then this error occurs:

error: Installed distribution kombu 3.0.0 conflicts with requirement kombu>=2.5.15,<3.0

Full error log:

It appears that celery is the one with the <3.0 dependency:


When I add a <3.0 to the kombu dependency on a fresh version before running the same command


Then the command succeeds


Change History (3)

comment:1 by criticalcat, 11 years ago

Priority: majorblocker

pythonsnake suggested blocker : )

comment:2 by Aleksej, 11 years ago

Cc: Aleksej added

comment:3 by pythonsnake, 10 years ago

Resolution: fixed
Status: newclosed


Note: See TracTickets for help on using tickets.