Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#755 closed defect (fixed)

"possibly undefined macro: AC_MSG_ERROR" is breaking the pyconfigure method

Reported by: cwebber Owned by:
Priority: critical Milestone: 0.6.0
Component: programming Keywords: bitesized
Cc: brandon Parent Tickets:

Description

On a fresh wheezy install with the normal mediagoblin dependencies as well as pkg-config and autoconf, I get the following error (and so do others on IRC):

cwebber@li313-33:~/mediagoblin$ ./bootstrap.sh && ./configure && make
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force 
autoreconf: configure.ac: tracing
autoreconf: configure.ac: not using Libtool
autoreconf: running: /usr/bin/autoconf --force
configure.ac:152: error: possibly undefined macro: AC_MSG_ERROR
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
autoreconf: /usr/bin/autoconf failed with exit status: 1

I'm not having this happen in Jessie, and IIRC I even had this working right in Wheezy. Some package must be missing? But without knowing what it is, we can't make this the official recommended way to set up MediaGoblin.

So, two steps:

  • First of all, change the docs so that the pyconfigure route is marked as "experimental" for now.
  • Figure out what's missing and document it!

Subtickets

Attachments (1)

755.patch (182 bytes) - added by lennax 4 years ago.
Addition of aclocal line to bootstrap.sh

Download all attachments as: .zip

Change History (11)

comment:1 Changed 4 years ago by brandon

I cannot reproduce this with Autoconf 2.69 in Parabola GNU/Linux or Arch Linux.

comment:2 Changed 4 years ago by cwebber

This was originally reported by someone in the #mediagoblin channel on freenode; indeed, I'm not getting the problem on my local machine. I tried from a fresh wheezy install though, and after installing the usual MediaGoblin requirements and autoconf + pkg-config only, I do indeed get this error.

I'm not sure what the source of the problem is. It's probably possible to reproduce in a VM?

I found various results for this, but failed to understand what their common link is... "installing pkg-config" as a solution clearly isn't the answer, because it's installed. But examples of the problem:

I don't know enough about autoconf to understand the root of the problem here, I'm afraid :\

comment:3 Changed 4 years ago by saulgoode

I believe it is necessary to run "aclocal -I m4 --install" before the "autoconf --force" gets executed in "bootstrap.sh".

Here is my log directly after checkout:

goblin@farnsworth:~/mediagoblin$ ./bootstrap.sh
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force
autoreconf: configure.ac: tracing
autoreconf: configure.ac: not using Libtool
autoreconf: running: /usr/bin/autoconf --force
configure.ac:152: error: possibly undefined macro: AC_MSG_ERROR

If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.

autoreconf: /usr/bin/autoconf failed with exit status: 1

goblin@farnsworth:~/mediagoblin$ aclocal -I m4 --install

goblin@farnsworth:~/mediagoblin$ ./bootstrap.sh
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force
autoreconf: configure.ac: tracing
autoreconf: configure.ac: not using Libtool
autoreconf: running: /usr/bin/autoconf --force
autoreconf: configure.ac: not using Autoheader
autoreconf: configure.ac: not using Automake
autoreconf: Leaving directory `.'
goblin@farnsworth:~/mediagoblin$

Last edited 4 years ago by saulgoode (previous) (diff)

comment:4 Changed 4 years ago by brandon

Ah nice to hear there's at least a work-around. If that's a reliable solution, it can simply be put inside the bootstrap.sh script.

comment:5 Changed 4 years ago by spaetz

I can confirm that "aclocal -I m4 --install" fixes things.

comment:6 Changed 4 years ago by cwebber

  • Keywords bitesized added

This would be an easy fix.

Changed 4 years ago by lennax

Addition of aclocal line to bootstrap.sh

comment:7 Changed 4 years ago by lennax

  • Status changed from new to review

I don't have a wheezy vm to test, but this patch should fix it. (OpenHatch task 81)

comment:8 Changed 4 years ago by brett

+1 to this patch. A fresh MediaGoblin clone tripped on this bug on my wheezy machine, and the patch let me go through the whole process successfully. I also don't know enough about autoconf to know if this is "correct," but it seems about as simple as simple can be.

comment:9 Changed 4 years ago by cwebber

  • Resolution set to fixed
  • Status changed from review to closed

Okay, great! I merged that fix. Thanks so much!

comment:10 Changed 4 years ago by cwebber

  • Milestone set to 0.6.0
Note: See TracTickets for help on using tickets.