Opened 16 months ago

Closed 3 weeks ago

#5621 closed defect (no-action)

Video media type not working

Reported by: Özcan Oğuz Owned by:
Priority: critical Milestone:
Component: programming Keywords: video, mediatypes, error
Cc: Parent Tickets:

Description

Hello everyone,

I have initialized a new instance on https://medya.oyd.org.tr and want to serve our conference's ([ozgurkon.org]) videos and slides from it; but when I tried to upload videos, it's not working.

First of all, I just added video media type and uploaded a demo video, but it stuck on "Processing" step. Then, I changed my mediagoblin.ini like this:

[[mediagoblin.media_types.video]]
available_resolutions = 144p,240p,360p,480p,720p,1080p
default_resolution = 1080p
[[[skip_transcode]]]
mime_types = video/webm, video/ogg, video/mp4, audio/ogg, application/ogg, application/x-annodex
container_formats = Matroska, Ogg, ISO MP4/M4A 
video_codecs = VP8 video, VP9 video, Theora, H.264, H.264 / AVC, MPEG-4 video
audio_codecs = Vorbis, MPEG-4 AAC audio
dimensions_match = false

But nothing changed. But I wanted to add media via {{{bin/gmg addmedia}} because I want to add ~20 GB of video. If I use this tool, video will appear on the site, but Video.js is not working and <source> tag is not exist on <video> block.

If I tried to reprocess a video that I uploaded via web with {{{bin/gmg reprocess}} I got this error:

WARNING:mediagoblin.processing:No idea what happened here, but it failed: TypeError("main_task() got multiple values for argument 'medium_size'",)
Traceback (most recent call last):
  File "bin/gmg", line 11, in <module>
    load_entry_point('mediagoblin', 'console_scripts', 'gmg')()
  File "/srv/medya.oyd.org.tr/mediagoblin/mediagoblin/gmg_commands/__init__.py", line 149, in main_cli
    args.func(args)
  File "/srv/medya.oyd.org.tr/mediagoblin/mediagoblin/gmg_commands/reprocess.py", line 293, in reprocess
    run(args)
  File "/srv/medya.oyd.org.tr/mediagoblin/mediagoblin/gmg_commands/reprocess.py", line 205, in run
    reprocess_info=reprocess_request)
  File "/srv/medya.oyd.org.tr/mediagoblin/mediagoblin/submit/lib.py", line 277, in run_process_media
    chord(wf[0])(wf[1])
  File "/srv/medya.oyd.org.tr/mediagoblin/lib/python3.6/site-packages/celery-4.1.0-py3.6.egg/celery/canvas.py", line 1196, in __call__
    return self.apply_async((), {'body': body} if body else {}, **options)
  File "/srv/medya.oyd.org.tr/mediagoblin/lib/python3.6/site-packages/celery-4.1.0-py3.6.egg/celery/canvas.py", line 1237, in apply_async
    body=body, task_id=task_id, **options)
  File "/srv/medya.oyd.org.tr/mediagoblin/lib/python3.6/site-packages/celery-4.1.0-py3.6.egg/celery/canvas.py", line 1251, in apply
    args=(tasks.apply(args, kwargs).get(propagate=propagate),),
  File "/srv/medya.oyd.org.tr/mediagoblin/lib/python3.6/site-packages/celery-4.1.0-py3.6.egg/celery/canvas.py", line 1011, in apply
    sig.apply(args=args, kwargs=kwargs, **options) for sig, _ in tasks
  File "/srv/medya.oyd.org.tr/mediagoblin/lib/python3.6/site-packages/celery-4.1.0-py3.6.egg/celery/canvas.py", line 1011, in <listcomp>
    sig.apply(args=args, kwargs=kwargs, **options) for sig, _ in tasks
  File "/srv/medya.oyd.org.tr/mediagoblin/lib/python3.6/site-packages/celery-4.1.0-py3.6.egg/celery/canvas.py", line 192, in apply
    return self.type.apply(args, kwargs, **options)
  File "/srv/medya.oyd.org.tr/mediagoblin/lib/python3.6/site-packages/celery-4.1.0-py3.6.egg/celery/app/task.py", line 741, in apply
    ret = tracer(task_id, args, kwargs, request)
  File "/srv/medya.oyd.org.tr/mediagoblin/lib/python3.6/site-packages/celery-4.1.0-py3.6.egg/celery/app/trace.py", line 388, in trace_task
    I, R, state, retval = on_error(task_request, exc, uuid)
  File "/srv/medya.oyd.org.tr/mediagoblin/lib/python3.6/site-packages/celery-4.1.0-py3.6.egg/celery/app/trace.py", line 374, in trace_task
    R = retval = fun(*args, **kwargs)
TypeError: main_task() got multiple values for argument 'medium_size'

I need to serve this videos, what should I do?

Subtickets

Change History (3)

comment:1 Changed 16 months ago by Özcan Oğuz

I fixed it temporarily by changing {{{mediagoblin/templates/mediagoblin/media_displays/video.html}} file as :

    {# for each_media_path in all_media_path #}
    <source src="{{ request.app.public_store.file_url(media.media_files.original) }}"
            {% if media.media_data %}
              type="{{ media.media_data.source_type() }}"
            {% else %}
              type="{{ media.media_manager['default_webm_type'] }}"
            {% endif %}
            label="{{ all_media_path }}" res="{{ all_media_path }}" />
    {# endfor #}

comment:2 Changed 6 months ago by Ben Sturmfels

Hi Özcan, sorry for the slow response. If this issue is still relevant, can you tell us what operating system you're running on? More recently I've added some Docker-based testing of the installation process on common platforms to avoid issues like you're seeing. Was the system deployed based on our https://mediagoblin.readthedocs.io/en/master/siteadmin/deploying.html guide, or some other approach?

Regards,
Ben

comment:3 Changed 3 weeks ago by Ben Sturmfels

Resolution: no-action-required
Status: newclosed

We haven't heard back from Özcan, so closing this ticket.

Note: See TracTickets for help on using tickets.