Opened 5 months ago

Closed 5 months ago

#5591 closed defect (duplicate)

Avoiding up-scaling low-res videos

Reported by: Ben Sturmfels Owned by:
Priority: minor Milestone: 0.11.0
Component: programming Keywords:
Cc: vijthaaa@… Parent Tickets:

Description (last modified by Ben Sturmfels)

Rose Irene wrote to the mailing list:

Hello dear developers

I was uploading videos with a resolution of 480p to my server but the videos
were also scaled to 1080p and 720p. Videos should be scaled from full resolution
to lower resolution. Example: 1080p to video 720p, 480p, 360p. but not 360p to
480p, 720p or 1080p

Regards,
Rose Irene

I've just tried this on the current master branch with the following 352x288 video and found that the video was transcoded to 360p, 480p and 720p.

https://upload.wikimedia.org/wikipedia/commons/2/25/Kleuters_vieren_gouden_jubileum.ogv

Vijeth, do you have any thoughts on how best to implement this check/skip? In the case that the original video is lower-res than all of the available_resolutions, I assume we would need to keep the original video, which is normally thrown away.

Subtickets

Change History (3)

comment:1 Changed 5 months ago by Ben Sturmfels

Description: modified (diff)

comment:2 Changed 5 months ago by Ben Sturmfels

Milestone: 0.11.0

comment:3 Changed 5 months ago by Ben Sturmfels

Resolution: duplicate
Status: newclosed

Closing as duplicate of #5509.

Note: See TracTickets for help on using tickets.