Opened 8 years ago

Closed 4 years ago

#542 closed defect (cant-reproduce)

Celeryd yields an error and then stops processing uploads

Reported by: thelovebug Owned by:
Priority: major Milestone:
Component: programming Keywords:
Cc: Parent Tickets:

Description

So I've uploaded a file to my instance, but it's totally ignoring it.. it's not even present in the processing panel. But if I kill celeryd, remove the pid, and restart celeryd, it'll pick it up.

I'm uploading files two or three times a week, and I have to do the kill-remove-restart thing each time.

Errors in mediagoblin-celeryd.log here:
http://paste.thelovebug.org/view/e1cbeb35

Subtickets

Change History (4)

comment:1 Changed 8 years ago by Christopher Allan Webber

Heya,

I have a suspicion of what's going on here. Could you show us a bit of detail of how you're launching the paste process?

I suspect celery is in "always eager" mode, which means that you have both celery processing inside of paste and separately both. That would lead to locking!

comment:2 Changed 8 years ago by Christopher Allan Webber

Milestone: 0.3.2

I'm going to leave this open for a week or so because it could be serious, but at the moment I don't think we have proof that it is... I still think this is related to paste and celery competing for access to that sqlite database. Need more info though!

comment:3 Changed 7 years ago by Elrond

Component: infrastructureprogramming

I don't know, but might be related #658 maybe?

comment:4 Changed 4 years ago by Ben Sturmfels

Resolution: worksforme
Status: newclosed

Closing this issue as we haven't received the necessary further information after several years. Please feel free to re-open if anyone has anything further to add.

Note: See TracTickets for help on using tickets.