Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#5394 closed defect (fixed)

Wrong url for forgot_password in basic_auth plugin

Reported by: jerome Owned by:
Priority: minor Milestone: 0.9.0
Component: programming Keywords: auth, views, routes
Cc: Parent Tickets:

Description

The endpoint used here does not exist and should surely be mediagoblin.plugins.basic_auth.forgot_password instead.

Attachments (1)

fix-basic_auth-views.patch (772 bytes ) - added by jerome 9 years ago.

Download all attachments as: .zip

Change History (4)

by jerome, 9 years ago

Attachment: fix-basic_auth-views.patch added

comment:1 by ayleph, 9 years ago

Keywords: auth views routes added
Priority: majorminor
Status: newreview

I just confirmed that this issue does exist, and that the attached patch does resolve the issue. Patch looks good to me.

This issue only pops up if you enter the name of a user which doesn't exist on the server, so I'm dropping the priority to minor. I'm also marking as ready for review, but I may go ahead and push if nobody else gets around to look at it.

It looks like we need test coverage here, but I'm not very familiar with creating unit tests.

comment:2 by Christopher Allan Webber, 8 years ago

Milestone: 0.9.0
Resolution: fixed
Status: reviewclosed

Test coverage would be nice, but is not necessary. I pushed the patch!

jerome, do you have a preferred name you'd like to be credited with in the next release, or would you like to stick with "jerome"?

comment:3 by jerome, 8 years ago

Sorry, I'm not really familiar with Trac and notifications yet, I just discovered your answers after reading your exciting article about the 0.9.0 release!... And realized that someone with the same first name than me was in the list of people to applause. I didn't except that with such a small contribution. So, thank you! I hope to contribute more in the future.

I take the opportunity to give a round of applause for your great work on MediaGoblin to you!!

Last edited 8 years ago by jerome (previous) (diff)
Note: See TracTickets for help on using tickets.