Opened 9 years ago

Closed 7 years ago

#535 closed defect (fixed)

Some files cause a mystery error - MakerNote Tag 0x0001

Reported by: Mark Holmquist Owned by:
Priority: major Milestone:
Component: programming Keywords:
Cc: Parent Tickets:

Description

This file was troublesome, for some reason. It is pretty big, but I'm not sure that's the problem.

Subtickets

Attachments (2)

debug.txt (5.2 KB) - added by Mark Holmquist 9 years ago.
The debug output, for your reference.
The Boys (scaled).jpg (192.3 KB) - added by Mark Holmquist 9 years ago.
File that broke the server

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by Mark Holmquist

Attachment: debug.txt added

The debug output, for your reference.

comment:1 Changed 9 years ago by Christopher Allan Webber

Interesting. It looks like EXIF.py (which we don't maintain) has some special code here relative to makernote stuff, and that it's broken somehow.

We also haven't pulled down a more recent EXIF.py in some time; I wonder if it's been fixed recently?

Last edited 9 years ago by Christopher Allan Webber (previous) (diff)

Changed 9 years ago by Mark Holmquist

Attachment: The Boys (scaled).jpg added

File that broke the server

comment:2 Changed 9 years ago by Christopher Allan Webber

If someone wants to tackle this bug, it would be good if they could try pulling in a more recent version of EXIF.py and see if that fixes it. If not, we should file a bug and possibly a fix upstream.

comment:3 Changed 9 years ago by bcordier

Tested the image with a newer version of EXIF.py (available at https://github.com/ianare/exif-py). The scripts returns all the exif infos with no error compared to the actual version in mediagoblin. Tested with mediagoblin by replacing the EXIF.py in /mediagoblin/extlib/exif/ and it works flawlessly, the image shows up on the website and no error appear. So apparently this new version fixes this bug.

comment:4 Changed 9 years ago by Deb

Owner: set to Deb
Status: newaccepted

comment:5 Changed 9 years ago by Christopher Allan Webber

Status: acceptedin_progress

Deb, are you working on this bug? I've set it in_progress and to you, not sure what's going on. Feel free to unclaim if you aren't presently working on it. Thanks!

comment:6 Changed 8 years ago by Deb

Hey there. 1) I have not done any work on this and 2) it seems like it is fixed once you update exif.py

I didn't look into this in any detail and so don't feel qualified to close this bug.

comment:7 Changed 7 years ago by Christopher Allan Webber

Owner: Deb deleted
Resolution: fixed
Status: in_progressclosed

We are indeed using a newer version now (via a library) and everything seems fine, so closing this ticket.

Note: See TracTickets for help on using tickets.