Opened 8 years ago

Closed 8 years ago

#528 closed defect (fixed)

pagination fails from user page

Reported by: ronny Owned by:
Priority: major Milestone:
Component: programming Keywords:
Cc: Parent Tickets:

Description

I experienced a problem, when trying to go to the second page of a user (https://example.org/u/username/). I just got a Server Error. After trying around, I could find out, that it had to do with a wrong URL in the NextPage Link.
Instead of:
https://example.org/u/username/gallery/?page=2
it should have been:
https://example.org/u/username/?page=2

In the file:
mediagoblin/templates/mediagoblin/utils/pagination.html

the "base_url" is set by "request.full_path". I tried to set it instead with "request.urlgen('mediagoblin.user_pages.user_home', user= request.user.username)" and it worked. But I am not sure if this would interfere with some other parts...

thanks in advance

Subtickets

Change History (6)

comment:1 Changed 8 years ago by ronny

OK just realized, that my solution doesnt work in anyways. If the user isnt logged in, it doesnt work. If soone not-logged-in is using the second page from the main page (https://example.org/), he gets to: https://example.org/?page=2, which shows the same Server Error.
I think the problem is somewhere with this page=2 parameter, it seems to work only (with restrictions) with the userpage..

comment:2 Changed 8 years ago by bigjust

Wasn't able to reproduce on the current code, is this still occurring?

comment:3 Changed 8 years ago by ronny

mmh still there, just did a git checkout, setup.py develop --upgrade && ./bin/gmg dbupdate and mediagoblin-paster restart.

maybe sth in combination with nginx? btw here are the errors:
http://pastebin.com/B986Lh0c

comment:4 Changed 8 years ago by bigjust

did that paste cut off? that doesn't look like the entire traceback

comment:5 Changed 8 years ago by ronny

nope xD
it just ends there..

comment:6 Changed 8 years ago by ronny

Resolution: fixed
Status: newclosed

after an recent update pagination seems to work!

Note: See TracTickets for help on using tickets.