Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#5066 closed defect (fixed)

Work around pbutils import warning bug

Reported by: anongoblin Owned by:
Priority: minor Milestone: 0.8.0
Component: programming Keywords:
Cc: Parent Tickets:

Description

Until bug 736260 in pygobject/pbutils has been fixed, we get these warnings whenever mediagoblin is run:

…/lib64/python2.7/site-packages/gi/module.py:178: Warning: g_array_append_vals: assertion 'array' failed
  g_type = info.get_g_type()
…/lib64/python2.7/site-packages/gi/module.py:178: Warning: g_hash_table_lookup: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()
…/lib64/python2.7/site-packages/gi/module.py:178: Warning: g_hash_table_insert_internal: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()

Attached is a patch to workaround it - run Gst.init() before the import.

Subtickets

Attachments (1)

GstPbutils_import_workaround.patch (1.2 KB) - added by anongoblin 6 years ago.
Patch for warnings from msm-

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by anongoblin

Patch for warnings from msm-

comment:1 Changed 6 years ago by ayleph

This ticket is a duplicate of #5035, but this one has a solution attached.

comment:2 Changed 6 years ago by Boris Bobrov

Milestone: 0.8.0
Status: newaccepted

comment:3 Changed 6 years ago by Boris Bobrov

Resolution: fixed
Status: acceptedclosed

Thank you very much, fixed in e8c0e78

comment:4 Changed 5 years ago by Boris Bobrov

fixed in 355d062. I have no idea what happened to the commit mentioned in the previous comment.

Note: See TracTickets for help on using tickets.