Opened 7 years ago

Closed 7 years ago

#5035 closed defect (duplicate)

gi warnings

Reported by: ayleph Owned by:
Priority: trivial Milestone:
Component: programming Keywords: gi, warning
Cc: Parent Tickets:

Description

I get the following warnings when I run bin/gmg dbupdate in v0.8.0.

(mediagoblin-0.8.0) ~/mediagoblin-0.8.0 $ bin/gmg dbupdate
/usr/lib/python2.7/site-packages/gi/module.py:178: Warning: g_array_append_vals: assertion 'array' failed
  g_type = info.get_g_type()
/usr/lib/python2.7/site-packages/gi/module.py:178: Warning: g_hash_table_lookup: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()
/usr/lib/python2.7/site-packages/gi/module.py:178: Warning: g_hash_table_insert_internal: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()

Are these safe to ignore? If so, would it make sense to suppress the warning output?

Subtickets

Change History (4)

comment:1 Changed 7 years ago by Boris Bobrov

They are absolutely safe to ignore.

I don't know how to suppress them without suppressing others though, so I will appreciate any help.

comment:2 Changed 7 years ago by Boris Bobrov

Component: infrastructureprogramming
Milestone: 0.8.0
Priority: minortrivial
Status: newaccepted

comment:3 Changed 7 years ago by ayleph

A solution to this has been proposed in duplicate ticket #5066.

comment:4 Changed 7 years ago by Boris Bobrov

Resolution: duplicate
Status: acceptedclosed

duplicate of #5066, thanks ayleph

Note: See TracTickets for help on using tickets.