Opened 9 years ago

Closed 6 years ago

#367 closed task (invalid)

atom feed shows a wrong URL when using apache with mod_proxy

Reported by: Michele Azzolari Owned by:
Priority: minor Milestone:
Component: documentation Keywords:
Cc: Parent Tickets:

Description (last modified by Christopher Allan Webber)

Setup: I have a virtual host for media.macno.org and I use
mod\_proxy to access my mediagoblin server (which listen on
127.0.0.1:6543)

Issue: atom feed self link uses a wrong url

For example requesting
`http://media.macno.org/u/macno/atom/ <http://media.macno.org/u/macno/atom/>`_
returns



Subtickets

Change History (5)

comment:1 Changed 9 years ago by Michele Azzolari

Fixed enabling the ProxyPreserveHost directive on Apache

::

    Alias /mgoblin_media "/var/www/media.macno.org/user_dev/media/public/"   
        Alias /mgoblin_static "/var/www/media.macno.org/mediagoblin/static/"
    
    ProxyPreserveHost On  
        ProxyPass /mgoblin_static/ !  
        ProxyPass /mgoblin_media/ !  
        ProxyPass / [http://127.0.0.1:6543/](http://127.0.0.1:6543/)  
        ProxyPassReverse / [http://127.0.0.1:6543/](http://127.0.0.1:6543/)



comment:2 Changed 9 years ago by Elrond

Component: Documentation
Owner: set to Michele Azzolari
Hi Michele,

I have assigned this bug to you. :)
If you don't like that, just undo it.

If you have the time and fun, you could create a new section on
your setup at
`http://wiki.mediagoblin.org/Deployment <http://wiki.mediagoblin.org/Deployment>`_
which would be great.



comment:3 Changed 9 years ago by Will Kahn-Greene

The original url for this bug was http://bugs.foocorp.net/issues/725 .

comment:4 Changed 7 years ago by Christopher Allan Webber

Description: modified (diff)
Owner: Michele Azzolari deleted

I don't believe this bug is being presently worked on so I'm removing ownership!

comment:5 Changed 6 years ago by Ben Sturmfels

Resolution: invalid
Status: acceptedclosed

In my experience the Atom feeds work correctly when using Nginx as a reverse proxy. This suggests that the issue here was just related to configuring Apache to pass through relevant headers, not a bug in MediaGoblin.

Since Apache mod_proxy is a less common approach to deployment, it's probably not worth attempting to document this. I'm going to be bold and close this ticket. If I've missed something, please don't hesitate to reopen the ticket.

(I would have preferred a resolution status of "no action". "Invalid" sounds unnecessarily aggressive.)

Note: See TracTickets for help on using tickets.