Opened 9 years ago

Closed 9 years ago

#270 closed enhancement (fixed)

Create shell scripts to ease launching of celeryd with a local .ini

Reported by: joar Owned by:
Priority: major Milestone: 0.3.0
Component: programming Keywords: bitesized
Cc: Parent Tickets:

Description (last modified by Christopher Allan Webber)

Use case¶
=========

Chewbacca launches ``./lazyserver.sh`` with the arguments
``-c mediagoblin_local.ini`` to prevent merge conflicts while still
having local changes from the default .ini.

One day, Chewbacca wants to be able to run celery in a separate
process. First, out of confusion he runs celery with

::

    CELERY_CONFIG_MODULE=mediagoblin.init.celery.from_celery ./bin/celeryd

This seems to work, but all the images are broken. Chewbacca
doesn't realise that the problem is that his public\_store is not
the ordinary public\_store but cloudfiles.

Chewbacca has to type

::

    export MEDIAGOBLIN_CONFIG=mediagoblin_local.ini; export CELERY_CONFIG_MODULE=mediagoblin.init.celery.from_celery; ./bin/celeryd

Chewbacca wants to type
``./lazycelery.sh -c mediagoblin_local.ini``



Subtickets

Change History (5)

comment:1 Changed 9 years ago by Christopher Allan Webber

This is a pleasantly simple task that I'm happy to walk anyone
through on IRC. :)



comment:2 Changed 9 years ago by Will Kahn-Greene

The original url for this bug was http://bugs.foocorp.net/issues/609 .
Relations:
#279: related

comment:3 Changed 9 years ago by Christopher Allan Webber

Description: modified (diff)
Keywords: bitesized added
Milestone: 0.2.2
Priority: minormajor
Type: defectenhancement

Marking this task as bitesized

comment:4 Changed 9 years ago by Brett Smith

Fixed in https://gitorious.org/~bretts/mediagoblin/brettss-mediagoblin/commits/bug270-lazycelery-script . I maybe made the task more than bitesized, but hopefully it's effort that will pay off. :)

comment:5 Changed 9 years ago by Christopher Allan Webber

Resolution: fixed
Status: acceptedclosed

Great work! I merged it! And nice work reducing redundancy in your solution :)

Note: See TracTickets for help on using tickets.