Opened 6 years ago

Closed 6 years ago

#898 closed defect (cant-reproduce)

Deployment doc: Mention bin/activate for running important commands.

Reported by: Daniel Krol Owned by:
Priority: minor Milestone:
Component: documentation Keywords:
Cc: Parent Tickets:

Description

On this page:

http://mediagoblin.readthedocs.org/en/latest/siteadmin/deploying.html

I see nothing about source bin/activate. That's required for running things such as the update command:

./bin/python setup.py develop --upgrade && ./bin/gmg dbupdate && git submodule fetch

Interestingly, the initial dependency installer command

(virtualenv --system-site-packages . || virtualenv .) && ./bin/python setup.py develop

doesn't leave you in the virtual env. I don't even know how setup.py works here. In fact, perhaps it's not working? The update command gave me a package error ( #896 ) which I did not have when running the initial installation command.

Subtickets

Change History (1)

comment:1 Changed 6 years ago by Christopher Allan Webber

Resolution: worksforme
Status: newclosed

It isn't required to source bin/activate actually, not with the way we've written our docs. The reason we run ./bin/python explicitly instead of just python is it uses the python within the context of the virtualenv, which will use the virtualenv's own library setup.

Note: See TracTickets for help on using tickets.