Opened 5 years ago

Closed 5 years ago

#859 closed defect (worksforme)

Celery uses the wrong broker

Reported by: joar Owned by:
Priority: critical Milestone: 0.7.0
Component: programming Keywords: celery
Cc: Parent Tickets:

Description

If I launch celery via ./lazycelery.sh, it can't connect to the broker.

[2014-03-22 14:54:42,938: ERROR/MainProcess] consumer: Cannot connect to amqp://guest@127.0.0.1:5672//: [Errno 111] Connection refused.
Trying again in 2.00 seconds...

[2014-03-22 14:54:44,952: ERROR/MainProcess] consumer: Cannot connect to amqp://guest@127.0.0.1:5672//: [Errno 111] Connection refused.
Trying again in 4.00 seconds...

[2014-03-22 14:54:48,965: ERROR/MainProcess] consumer: Cannot connect to amqp://guest@127.0.0.1:5672//: [Errno 111] Connection refused.
Trying again in 6.00 seconds...

Subtickets

Change History (4)

comment:1 Changed 5 years ago by joar

The broker should be an sqlite URL, not the amqp URL that's a celery default.

comment:2 Changed 5 years ago by digital-dreamer

From your mediagoblin installation folder, run this command

bin/gmg dbupdate

This fixes the URLs, you should now be able to run your server.
If the problem persists, open this file

local/mediagoblin/config_spec.ini

and verify that this section is intact

[celery]
# default result stuff
CELERY_RESULT_BACKEND = string(default="database")
CELERY_RESULT_DBURI = string(default="sqlite:///%(here)s/celery.db")

# default kombu stuff
BROKER_TRANSPORT = string(default="sqlalchemy")
BROKER_URL = string(default="sqlite:///%(here)s/kombu.db")

comment:3 Changed 5 years ago by Christopher Allan Webber

Milestone: 0.7.0

comment:4 Changed 5 years ago by Jessica Tallon

Resolution: worksforme
Status: newclosed

I've been unable to reproduce this so I'm closing this. If this is still an issue please re-open with more information on how to reproduce.

Note: See TracTickets for help on using tickets.