Opened 10 years ago

Closed 10 years ago

#844 closed defect (fixed)

Build tries to install pip 0.7.2 then explodes because it's not pip > 1.0

Reported by: muhoo Owned by:
Priority: major Milestone:
Component: programming Keywords:
Cc: Parent Tickets:


This happens:

Adding mock 1.0.1 to easy-install.pth file

Installed /srv/mediagoblin/mediagoblin/lib/python2.6/site-packages/mock-1.0.1-py2.6.egg
Searching for sqlalchemy-migrate
Best match: sqlalchemy-migrate 0.8.2
Processing sqlalchemy-migrate-0.8.2.tar.gz
Running sqlalchemy-migrate-0.8.2/ -q bdist_egg --dist-dir /tmp/easy_install-JuvxIg/sqlalchemy-migrate-0.8.2/egg-dist-tmp-AD0JJO
Checking .pth file support in .
/srv/mediagoblin/mediagoblin/bin/python -E -c pass
Searching for pbr
Best match: pbr 0.5.23
Processing pbr-0.5.23.tar.gz
Running pbr-0.5.23/ -q bdist_egg --dist-dir /tmp/easy_install-JuvxIg/sqlalchemy-migrate-0.8.2/temp/easy_install-9Cpbpz/pbr-0.5.23/egg-dist-tmp-A1mt19

Installed /tmp/easy_install-JuvxIg/sqlalchemy-migrate-0.8.2/pbr-0.5.23-py2.6.egg
error: Installed distribution pip 0.7.2 conflicts with requirement pip>=1.0
make: * [develop] Error 1

But... the pip installed is 1.5.2
pip 1.5.2 from /usr/local/lib/python2.6/dist-packages (python 2.6)

Not clear

1) Why is the build trying to install pip when pip is already installed?

2) Why is the build installing an OLDER version of pip than what is installed?

3) Why is the build installing an old version of pip than is required by other packages in the same build?

Change History (1)

comment:1 by muhoo, 10 years ago

Resolution: fixed
Status: newclosed

Aggh, solution was:

sudo pip install -U virtualenv

then the install worked.

Note: See TracTickets for help on using tickets.