Opened 10 years ago

Closed 3 years ago

#809 closed defect (no-action)

Inconsistency between https://issues.mediagoblin.org/report/9 and ticket statuses in this Trac instance

Reported by: Aleksej Owned by:
Priority: minor Milestone:
Component: infrastructure Keywords:
Cc: Parent Tickets:

Description

Some of the ticket status values in this Trac instance are:

  • new (like UNCONFIRMED in Bugzilla)
  • accepted (= confirmed, like NEW in Bugzilla)
  • in_progress (like ASSIGNED in Bugzilla)

Trac demo http://trac.edgewall.org/demo-1.0/ has at least:

  • new
  • accepted (= has an owner)

http://issues.mediagoblin.org/report/9 has sections "Accepted" and "Owned". "Accepted" shows "accepted" tickets, which have no owner. "Owned" shows "new" and "in_progress" tickets. The "in_progress" tickets I've seen have an owner, but "new" tickets do not, so the "Owned" section is filled/called incorrectly.

Change History (4)

comment:1 by Christopher Allan Webber, 10 years ago

This is intentional. We have to get rid of some of the old states.

I discussed the design for this on the mailing list: http://lists.mediagoblin.org/pipermail/devel/2013-May/000537.html

So, this is by design. However, the old states still appear in the issue list and can be removed. Removing them is not hard... their "legacy" just needs to be removed from the trac config.

I'm looking at cleaning that up now.

comment:2 by Christopher Allan Webber, 10 years ago

Resolution: fixed
Status: newclosed

Okay, I cleaned up the config. The old states of "accepted" and "reopened" have been removed from everywhere in the config.

comment:3 by Aleksej, 10 years ago

Resolution: fixed
Status: closedaccepted

https://issues.mediagoblin.org/report/9 still has an "Owned" section showing unassigned tickets. That's what I filed this about. Apparently you have to use https://issues.mediagoblin.org/wiki/TracReports to find out what's wrong.

comment:4 by Ben Sturmfels, 3 years ago

Resolution: no-action-required
Status: acceptedclosed

Closing this - Trac is too much of a pain already for me to be bother with this nitty-gritty detail.

Note: See TracTickets for help on using tickets.