Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#771 closed defect (fixed)

gstreamer 1.0 branch (was: could not get any video data from playbin)

Reported by: Danilo Tomasoni Owned by:
Priority: major Milestone: 0.8.0
Component: programming Keywords:
Cc: Parent Tickets:

Description

2013-09-16 14:52:43,825 DEBUG   [mediagoblin.processing.task] Processing <MediaEntry 1: Servizio TG su Trento VEG 2a edizione>
2013-09-16 14:52:43,826 INFO    [mediagoblin.media_types.video.transcoders] Initializing VideoTranscoder...
2013-09-16 14:52:43,827 INFO    [mediagoblin.media_types.video.transcoders] Discovering /home/mediagoblin/mediagoblin/user_dev/media/queue/media_entries/3911aebb-f702-4130-85bc-ab60ec05591e/corto.mp4
2013-09-16 14:52:44,748 INFO    [mediagoblin.media_types.video.transcoders] Terminating MainLoop
2013-09-16 14:52:44,914 INFO    [mediagoblin.media_types.video.transcoders] Discovering...
2013-09-16 14:52:44,922 INFO    [mediagoblin.media_types.video.transcoders] Done
2013-09-16 14:52:45,350 INFO    [mediagoblin.media_types.video.transcoders] Transcoding...
2013-09-16 14:52:46,376 INFO    [mediagoblin.media_types.video.transcoders] 0% done...
2013-09-16 14:52:58,610 INFO    [mediagoblin.media_types.video.transcoders] 3% done...
2013-09-16 14:53:10,042 INFO    [mediagoblin.media_types.video.transcoders] 7% done...
2013-09-16 14:53:20,066 INFO    [mediagoblin.media_types.video.transcoders] 11% done...
2013-09-16 14:53:33,537 INFO    [mediagoblin.media_types.video.transcoders] 15% done...
2013-09-16 14:53:50,396 INFO    [mediagoblin.media_types.video.transcoders] 19% done...
2013-09-16 14:54:11,345 INFO    [mediagoblin.media_types.video.transcoders] 23% done...
2013-09-16 14:54:29,514 INFO    [mediagoblin.media_types.video.transcoders] 26% done...
2013-09-16 14:54:50,641 INFO    [mediagoblin.media_types.video.transcoders] 30% done...
2013-09-16 14:55:08,717 INFO    [mediagoblin.media_types.video.transcoders] 34% done...
2013-09-16 14:55:27,070 INFO    [mediagoblin.media_types.video.transcoders] 38% done...
2013-09-16 14:55:47,575 INFO    [mediagoblin.media_types.video.transcoders] 42% done...
2013-09-16 14:56:05,465 INFO    [mediagoblin.media_types.video.transcoders] 46% done...
2013-09-16 14:56:25,856 INFO    [mediagoblin.media_types.video.transcoders] 50% done...
2013-09-16 14:56:44,589 INFO    [mediagoblin.media_types.video.transcoders] 53% done...
2013-09-16 14:57:04,668 INFO    [mediagoblin.media_types.video.transcoders] 57% done...
2013-09-16 14:57:23,415 INFO    [mediagoblin.media_types.video.transcoders] 61% done...
2013-09-16 14:57:40,336 INFO    [mediagoblin.media_types.video.transcoders] 65% done...
2013-09-16 14:58:01,071 INFO    [mediagoblin.media_types.video.transcoders] 69% done...
2013-09-16 14:58:17,247 INFO    [mediagoblin.media_types.video.transcoders] 73% done...
2013-09-16 14:58:33,054 INFO    [mediagoblin.media_types.video.transcoders] 76% done...
2013-09-16 14:58:53,354 INFO    [mediagoblin.media_types.video.transcoders] 80% done...
2013-09-16 14:59:16,081 INFO    [mediagoblin.media_types.video.transcoders] 84% done...
2013-09-16 14:59:35,581 INFO    [mediagoblin.media_types.video.transcoders] 88% done...
2013-09-16 14:59:55,625 INFO    [mediagoblin.media_types.video.transcoders] 92% done...
2013-09-16 15:00:13,669 INFO    [mediagoblin.media_types.video.transcoders] 96% done...
2013-09-16 15:00:41,954 INFO    [mediagoblin.media_types.video.transcoders] 100% done...
2013-09-16 15:00:41,962 INFO    [mediagoblin.media_types.video.transcoders] Done
2013-09-16 15:00:42,216 INFO    [mediagoblin.media_types.video.transcoders] Terminating MainLoop
2013-09-16 15:00:42,238 DEBUG   [mediagoblin.media_types.video.processing] Saving medium...
/home/mediagoblin/mediagoblin/local/lib/python2.7/site-packages/SQLAlchemy-0.8.2-py2.7-linux-i686.egg/sqlalchemy/engine/default.py:471: SAWarning: Unicode type received non-unicode bind param value.
  processors[key](compiled_params[key])
2013-09-16 15:00:42,288 DEBUG   [mediagoblin.media_types.video.processing] Saved medium
2013-09-16 15:00:42,668 INFO    [mediagoblin.media_types.video.transcoders] playbin ready
2013-09-16 15:00:42,669 CRITICA [mediagoblin.media_types.video.transcoders] Could not get any video data from playbin
/home/mediagoblin/mediagoblin/mediagoblin/media_types/video/transcoders.py:243: DeprecationWarning: integer argument expected, got float
  0)
2013-09-16 15:00:42,966 INFO    [mediagoblin.media_types.video.transcoders] Could not seek.
/home/mediagoblin/mediagoblin/mediagoblin/media_types/video/transcoders.py:243: DeprecationWarning: integer argument expected, got float
  0)
2013-09-16 15:00:42,968 INFO    [mediagoblin.media_types.video.transcoders] Could not seek.
/home/mediagoblin/mediagoblin/mediagoblin/media_types/video/transcoders.py:243: DeprecationWarning: integer argument expected, got float
  0)
2013-09-16 15:00:42,978 INFO    [mediagoblin.media_types.video.transcoders] Could not seek.
/home/mediagoblin/mediagoblin/mediagoblin/media_types/video/transcoders.py:243: DeprecationWarning: integer argument expected, got float
  0)
2013-09-16 15:00:42,981 INFO    [mediagoblin.media_types.video.transcoders] Could not seek.
/home/mediagoblin/mediagoblin/mediagoblin/media_types/video/transcoders.py:243: DeprecationWarning: integer argument expected, got float
  0)
2013-09-16 15:00:42,990 INFO    [mediagoblin.media_types.video.transcoders] Could not seek.
/home/mediagoblin/mediagoblin/mediagoblin/media_types/video/transcoders.py:243: DeprecationWarning: integer argument expected, got float
  0)
2013-09-16 15:00:42,993 INFO    [mediagoblin.media_types.video.transcoders] Could not seek.
/home/mediagoblin/mediagoblin/mediagoblin/media_types/video/transcoders.py:243: DeprecationWarning: integer argument expected, got float
  0)
2013-09-16 15:00:42,996 INFO    [mediagoblin.media_types.video.transcoders] Could not seek.
/home/mediagoblin/mediagoblin/mediagoblin/media_types/video/transcoders.py:243: DeprecationWarning: integer argument expected, got float
  0)
2013-09-16 15:00:43,002 INFO    [mediagoblin.media_types.video.transcoders] Could not seek.
/home/mediagoblin/mediagoblin/mediagoblin/media_types/video/transcoders.py:243: DeprecationWarning: integer argument expected, got float
  0)
2013-09-16 15:00:43,007 INFO    [mediagoblin.media_types.video.transcoders] Could not seek.
/home/mediagoblin/mediagoblin/mediagoblin/media_types/video/transcoders.py:243: DeprecationWarning: integer argument expected, got float
  0)
2013-09-16 15:00:43,010 INFO    [mediagoblin.media_types.video.transcoders] Could not seek.
/home/mediagoblin/mediagoblin/mediagoblin/media_types/video/transcoders.py:243: DeprecationWarning: integer argument expected, got float
  0)
2013-09-16 15:00:43,043 INFO    [mediagoblin.media_types.video.transcoders] Seek successful, attaching buffer probe
2013-09-16 15:00:43,044 INFO    [mediagoblin.media_types.video.transcoders] Attached buffer probes: {'fakesink0': 228L}
2013-09-16 15:00:43,045 INFO    [mediagoblin.media_types.video.transcoders] Already processing thumbnail
2013-09-16 15:00:43,046 INFO    [mediagoblin.media_types.video.transcoders] Already processing thumbnail
2013-09-16 15:00:43,046 INFO    [mediagoblin.media_types.video.transcoders] Already processing thumbnail
2013-09-16 15:00:43,047 INFO    [mediagoblin.media_types.video.transcoders] Already processing thumbnail
2013-09-16 15:00:43,048 INFO    [mediagoblin.media_types.video.transcoders] Already processing thumbnail
2013-09-16 15:00:43,049 INFO    [mediagoblin.media_types.video.transcoders] Already processing thumbnail
2013-09-16 15:00:43,197 INFO    [mediagoblin.media_types.video.transcoders] Already processing thumbnail
2013-09-16 15:00:43,197 INFO    [mediagoblin.media_types.video.transcoders] Already processing thumbnail
2013-09-16 15:00:45,962 CRITICA [mediagoblin.media_types.video.transcoders] Reached gobject timeout
2013-09-16 15:00:46,034 DEBUG   [mediagoblin.media_types.video.processing] Saving thumbnail...

this is the error I get on a newly installed mg 0.5.0
OS: debian 7.0.

Subtickets

Change History (13)

comment:1 Changed 9 years ago by Boris Bobrov

This should be fixed in gst10 branch of https://gitorious.org/mediagoblin/bretons-mediagoblin/ because playbin was removed

comment:2 Changed 9 years ago by Boris Bobrov

Status: newreview

comment:3 Changed 8 years ago by ayleph

This is a fairly common message, and it doesn't necessarily indicate a problem. Sometimes the playbin requires a couple of attempts to get playback data. The important part is that a thumbnail was created, which is the desired outcome.

I don't think this is an actual issue; it's just debug messages doing what they're supposed to do. I propose to mark this issue closed/invalid.

comment:4 Changed 8 years ago by Boris Bobrov

Owner: set to Boris Bobrov
Status: reviewin_progress

This does indicate a problem, though it was solved in my branch. This ticket needs to be closed after Chris and I review my code and merge it.

I'll assign the bug on me for now and change its status.

comment:5 Changed 8 years ago by starwar46

Facing the exact issues, in my case I experienced:

  1. Screenshot/thumbnail captured successfully and it gets displayed on the album page properly.
  2. Playback of the video results in audio only, no video.

I am hoping that this is confirmed as a bug and will be fixed soon, any updates?

comment:6 Changed 8 years ago by Boris Bobrov

Milestone: 0.8.0

new_gst10 branch in bretons-mediagoblin on gitorious.

comment:7 Changed 8 years ago by Christopher Allan Webber

breton:

I'm testing this merged with git master... audio works great! Unfortunately I'm hitting a problem with video:

File '/home/cwebber/devel/mediagoblin/mediagoblin/processing/task.py', line 101 in run
  processor.process(**reprocess_info)
File '/home/cwebber/devel/mediagoblin/mediagoblin/media_types/video/processing.py', line 385 in process
  vp8_threads=vp8_threads, vorbis_quality=vorbis_quality)
File '/home/cwebber/devel/mediagoblin/mediagoblin/media_types/video/processing.py', line 275 in transcode
  dimensions=tuple(medium_size))
File '/home/cwebber/devel/mediagoblin/mediagoblin/media_types/video/transcoders.py', line 191 in transcode
  self.__setup_videoscale_capsfilter()
File '/home/cwebber/devel/mediagoblin/mediagoblin/media_types/video/transcoders.py', line 330 in __setup_videoscale_capsfilter
  caps_struct.set_value('pixel-aspect-ratio', Gst.Fraction(1, 1))
TypeError: object() takes no parameters

This has happened with all files I've tried updating. I'm using Debian testing over here.

Here's an example file I'm having problems with: http://dustycloud.org/tmp/creature_teaser.ogg

comment:8 Changed 8 years ago by Boris Bobrov

Could you please post your output of "dpkg-query -s python-gst-1.0"?

comment:9 Changed 8 years ago by Christopher Allan Webber

Owner: Boris Bobrov deleted
Resolution: fixed
Status: in_progressclosed
Summary: could not get any video data from playbingstreamer 1.0 branch (was: could not get any video data from playbin)

So yeah, python-gst-1.0 wasn't specified by the docs, but now it is! And everything seems to be working well... now merged!

Whooooooo! Thanks for your long work on this, breton!

comment:10 Changed 8 years ago by ayleph

Something doesn't seem to work right in the merge. When I run dbupdate, I get:

  File "/srv/mediagoblin/mediagoblin-dev/mediagoblin/media_types/tools.py", line 20, in <module>
    import gi
ImportError: No module named gi

So I installed gi-1.2 via pip. Now when I run dbupdate, I get:

  File "/srv/mediagoblin/mediagoblin-dev/mediagoblin/media_types/tools.py", line 21, in <module>
    gi.require_version('Gst', '1.0')
AttributeError: 'module' object has no attribute 'require_version'

I'm running in a python2.7 environment.

comment:11 Changed 8 years ago by ayleph

I found a workaround to my problem. It's not really intuitive though.

I already had the following Arch Linux repository packages installed on my machine:

pygobject2-devel
python2-gobject2

I used pip to remove gi-1.2 from my virtualenv. I used my package manager to install gobject-introspection which didn't solve the issue. Then I used my package manager to install python2-gobject which also pulled in pygobject-devel (py3 version).

It seems that I already had "Python 2 bindings for GObject2" but I was missing "Python 2 bindings for GObject." I don't really get it, but it seems to have worked.

I had warnings about being unable to load plugins for libgstkate.so and libgstopencv.so, but I think I'm okay with that.

comment:12 Changed 8 years ago by sazius

Just a note that it seems to be hard to get the right version on Debian wheezy (current stable). There is no python-gst-1.0 in the repos and gi-1.2 via pip doesn't work either as ayleph said.

comment:13 Changed 8 years ago by Boris Bobrov

gi is not the package you want. I don't know what's the name of the package on pypi and suggest using packages listed on http://mediagoblin.readthedocs.org/en/latest/siteadmin/media-types.html#video

python-gst-1.0 is in debian testing, which is now in freeze. Supporting both gst-0.10 and gst-1.0 branches was not easy and we decided not to include gst-0.10. Maybe it will be in 0.8.1 (though I cannot promise)

Note: See TracTickets for help on using tickets.