Improve checkbox wording
|Reported by:||spaetz||Owned by:|
Please review and pull my branch fix_wording from my repo at git://gitorious.org/mediagoblin/spaetz-mediagoblin.git.
Do not describe a checkbox as "Enable/Disable notifications". So what does what?
Pull post-release or the translations will break, I guess.