Opened 9 years ago

Closed 9 years ago

#646 closed defect (fixed)

Problem with ./bin/gmg theme assetlink

Reported by: Tumulte Owned by: Christopher Allan Webber
Priority: blocker Milestone: 0.3.3
Component: programming Keywords:
Cc: Parent Tickets:

Description (last modified by Christopher Allan Webber)

./bin/gmg theme assetlink gives me this error :

  File "./bin/gmg", line 9, in <module>
    load_entry_point('mediagoblin==0.3.3.dev', 'console_scripts', 'gmg')()
  File "/var/www/mediagoblin/mediagoblin/gmg_commands/__init__.py", line 100, in main_cli
    args.func(args)
  File "/var/www/mediagoblin/mediagoblin/gmg_commands/theme.py", line 122, in theme
    SUBCOMMANDS[args.subcommand](args)
  File "/var/www/mediagoblin/mediagoblin/gmg_commands/theme.py", line 104, in assetlink_command
    link_assets(current_theme, app_config['theme_linked_assets_dir'])
  File "/var/www/mediagoblin/mediagoblin/gmg_commands/theme.py", line 71, in link_assets
    printer(_("No asset directory for this theme\n"))
  File "/var/www/mediagoblin/mediagoblin/tools/translate.py", line 122, in pass_to_ugettext
    return mg_globals.thread_scope.translations.ugettext(
AttributeError: 'NoneType' object has no attribute 'ugettext'

Subtickets

Change History (3)

comment:1 Changed 9 years ago by Christopher Allan Webber

Milestone: 0.3.3
Owner: set to Christopher Allan Webber
Priority: majorblocker
Status: newassigned

This is blocking the next release.

Luckily, I've found the cause and am working on a fix. It has to do with the changes between the commits 7989cd6, 7b9f9d1.

comment:2 Changed 9 years ago by Christopher Allan Webber

Description: modified (diff)

comment:3 Changed 9 years ago by Christopher Allan Webber

Resolution: fixed
Status: assignedclosed

Fixed. We stopped setting a default translations gettext in mg_globals.py. I set that back and set a docstring explaining why we needed it.

Note: See TracTickets for help on using tickets.