Opened 4 months ago

Last modified 4 months ago

#5613 accepted defect

Configuration for default video quality

Reported by: TmCTux Owned by:
Priority: minor Milestone:
Component: programming Keywords:
Cc: Parent Tickets:

Description

with 0.10 version, a nice enhancement for video quality selection. 3 level are available by default (360, 480 and 720p), is there any configuration to generate only some of them and what matter more for me is could we force a default quality for the user, actually it's the lowest by default, which poorly show quality works for people not knowing how to change the quality...

thanks a lot again,

Subtickets

Change History (7)

comment:1 Changed 4 months ago by Ben Sturmfels

Here's what you need in your mediagoblin.ini configuration file:

# List of resolutions that the video should be transcoded to
# Choose among ['144p', '240p', '360p', '480p', '720p', '1080p'],
# preferrably in the order of transcoding.
available_resolutions = ['480p', '360p', '720p']

# Default resolution of video
default_resolution = '480p'

We need to add this to the documentation for media types, so leaving this ticket open.

comment:2 Changed 4 months ago by Ben Sturmfels

Priority: majorminor
Status: newaccepted

comment:3 Changed 4 months ago by TmCTux

Hello,

looks like indeed to what I was looking for, but I can't make it working.
I'm putting those in the mediagoblin_local.ini files, maybe I'm not putting it in the right section (I've tried several) but I either can't restart the server (paste service fail on config files) or it has no impact (I was expected for the default resolution that it will be the one selected by default when you play a video).

thanks again for replying

comment:4 Changed 4 months ago by TmCTux

so I had a look in the code, I believe those conf should go under the part
[[mediagoblin.media_types.video]]
but "available_resolutions" raises a syntax error and default_resolution (if put alone to be able to launch the server) has no effect as stated earlier.

Indeed, when looking into "mediagoblin/media_types/video/config_spec.ini", I can see that default_resolution is already set by default at 480p (I wanted 720p but still) and default resolution is always 360p when accessing a video on the site.
Maybe I don't get what this default settings do but it doesn't seem to work as intended.
--

Last edited 4 months ago by TmCTux (previous) (diff)

comment:5 Changed 4 months ago by TmCTux

Component: documentationprogramming
Type: enhancementdefect

comment:6 Changed 4 months ago by Ben Sturmfels

TmCTux, I've just tested these settings and similarly found that the default_resolution doesn't seem to work. Also I'd given you the wrong form at for the available_resolutions. Here's my config:

[[mediagoblin.media_types.video]]
available_resolutions = 144p,240p
default_resolution = 240p

With this config I correctly got 144p and 240p transcoded, but the 144p video was displayed by default in the player.

comment:7 Changed 4 months ago by Ben Sturmfels

I've updated the source documentation now:
http://git.savannah.gnu.org/cgit/mediagoblin.git/commit/?id=9308959be28da444e6875691fef14a635b79339d

Not yet visible in the published docs.

Note: See TracTickets for help on using tickets.