Opened 4 years ago

Closed 3 years ago

#5472 closed defect (cant-reproduce)

Error to load video...

Reported by: e-holy Owned by:
Priority: major Milestone:
Component: programming Keywords:
Cc: Parent Tickets:

Description

My error is:

GStreamer: gst-library-error-quark: Could not initialize supporting library. (3)

when i will load an video...

My system is:

4.7.2-201.fc24.x86_64 - Linux/Fedora 24/x86_64

---

2016-09-07 10:35:37,350 INFO [mediagoblin.media_types] Info about file found, checking further
2016-09-07 10:35:37,350 INFO [mediagoblin.media_types] checking the contents with sniffer
2016-09-07 10:35:37,350 INFO [mediagoblin.media_types.video.processing] Sniffing mediagoblin.media_types.video
2016-09-07 10:35:37,352 INFO [mediagoblin.media_types.tools] Discovering /tmp/tmpIcADjv...
error: XDG_RUNTIME_DIR not set in the environment.
error: XDG_RUNTIME_DIR not set in the environment.
2016-09-07 10:35:37,364 WARNING [mediagoblin.media_types.video.processing] GStreamer: gst-library-error-quark: Could not initialize supporting library. (3)
2016-09-07 10:35:37,364 INFO [mediagoblin.media_types] sniffer says it will not accept the file

Subtickets

Change History (2)

comment:1 Changed 4 years ago by Ben Sturmfels

Hi e-holy,

Thanks very much for taking the time to report this issue. Could I ask you to gather some details about the video itself so we can investigate? I'd like to know what media codec is used in the original. You can find this by either:

  1. Opening in Totem, showing the sidebar (View, Sidebar) and noting the Video and Audio details, or
  1. Opening in VLC, selecting Tools, Codec information.

Let us know how you go.

Regards,
Ben

comment:2 Changed 3 years ago by ayleph

Resolution: worksforme
Status: newclosed

This most likely indicates a missing codec on the computer running MediaGoblin. Make sure you've installed all relevant gstreamer packages. I'm going to close this since there's been no additional information from the reporter.

Note: See TracTickets for help on using tickets.