Opened 4 years ago

Closed 2 years ago

#5470 closed defect (cant-reproduce)

Fix "setup.py develop --upgrade" on Ubuntu 14.04

Reported by: randfur Owned by:
Priority: major Milestone:
Component: programming Keywords:
Cc: Parent Tickets:

Description

This is a patch that makes "setup.py develop --upgrade" work on my Ubuntu 14.04 laptop. Without it I get several depenency misses.

diff --git a/setup.py b/setup.py
index 608a01d..3c81e66 100644
--- a/setup.py
+++ b/setup.py
@@ -48,6 +48,9 @@ if PY2:
     pyversion_install_requires.append('ExifRead')
 
 install_requires = [
+    'docutils',
+    'imagesize',
+    'markupsafe',
     'waitress',
     'alembic>=0.7.5',
     'python-dateutil',
@@ -67,7 +70,7 @@ install_requires = [
     'itsdangerous',
     'pytz',
     'sphinx',
-    'six',
+    'six>=1.7.0',
     'oauthlib',
     'unidecode',
     'jsonschema',

Note that this is after running
sudo apt-get install git-core python python-dev python-lxml python-imaging python-virtualenv python-gst-1.0 libjpeg8-dev autoconf

Subtickets

Change History (2)

comment:1 Changed 4 years ago by Ben Sturmfels

Hi Alan,

Thanks so much for spending hacking MediaGoblin with us at PyConAU! Was wonderful to meet you. :)

It looks like there have been a couple of changes that have improved the development environment installation process for me, and perhaps you too.

I was just able to flawlessly clone a fresh copy of master, run ./bootstrap.sh && ./configure --with-python3 && make, then bin/gmg dbupdate and ./lazyserver.sh. I realise this is Python 3 of course, and we're running different distributions, but would you mind having another shot at a clean install to see what, of the above patch, is still required for you?

Thanks heaps, hope to catch you again soon!

Ben

comment:2 Changed 2 years ago by ayleph

Resolution: worksforme
Status: newclosed

The last update to this ticket indicate the problem indicated in the ticket isn't an issue, and the original submitter hasn't responded in 19 months. I'm going to go ahead and close this, but feel free to re-open if you're still seeing this problem on recent code.

Note: See TracTickets for help on using tickets.