Opened 6 years ago

Closed 6 years ago

#5453 closed defect (duplicate)

migration will fail when disable a previously enabled plugin

Reported by: 宋文武 Owned by:
Priority: major Milestone:
Component: programming Keywords:
Cc: Parent Tickets:

Description

steps:

Enable mediagoblin.media_types.blog.
Run gmg dbupdate, OK.
Disable mediagoblin.media_types.blog.
Run gmg dbupdate, FAIL.

with Traceback:

KeyError: '562bc42a8fff'...
alembic.util.CommandError: Can't locate revision identified by '562bc42a8fff'...

After search, it's same as:
https://stackoverflow.com/questions/32311366/alembic-util-command-error-cant-find-identifier

If I delete '562bc42a8fff' from the alembic_version table manually,
it will works.

Subtickets

Change History (1)

comment:1 Changed 6 years ago by Christopher Allan Webber

Resolution: duplicate
Status: newclosed

Thanks for the report iyzsong! I think this is a duplicate of #5447 though?

Anyway, it's annoying. I hope we can make progress on it.

Note: See TracTickets for help on using tickets.