Opened 5 years ago

Closed 5 years ago

#5389 closed enhancement (fixed)

Dokku and Docker support

Reported by: Loic Dachary Owned by:
Priority: major Milestone:
Component: programming Keywords:
Cc: Laura Arjona Reina Parent Tickets:

Description

Make is so it is possible to run mediagoblin as a dokku application ( http://dokku.viewdocs.io/dokku/ ).

Subtickets

Change History (21)

comment:1 Changed 5 years ago by Loic Dachary

Owner: set to Loic Dachary
Status: newin_progress

Dokku instance running as described at https://notabug.org/dachary/mediagoblin-docker/ has:

Maybe that would be useful as a building block for premium hosting ( http://mediagoblin.org/pages/campaign.html ) ?

Last edited 5 years ago by Loic Dachary (previous) (diff)

comment:2 Changed 5 years ago by Loic Dachary

Owner: Loic Dachary deleted
Status: in_progressreview

comment:3 Changed 5 years ago by Loic Dachary

Summary: dokku supportDokku and Docker support

comment:4 Changed 5 years ago by Loic Dachary

Suggested change to the website, assuming the repository is under the mediagoblin namespace and not the dachary namespace : https://notabug.org/dachary/mediagoblin-website/commit/b3d846266249d3bd59aa7e9aee4b76bede57de6e

comment:5 Changed 5 years ago by Christopher Allan Webber

So first of all, awesome, and thank you Loic! I'm glad to see this.

Docker images will be very convenient towards getting people up and running fast with MediaGoblin, which is great, and Docker is also very popular, so allowing people to use tools they're already using is also pretty important.

I'm a bit hesitant to promote it so strongly as *the* way to get things up and running fast. I'm not sold on Docker myself, and I'm not sure we should promote it as if we were so confident in it. I'm still hoping for much more reproducible systems such as Guix.

That said, hey, this instance here has a nicely documented dockerfile, and clearly it's something people *want*, so I can be convinced we should add it. Any other opinions? Despite my curmudgeonliness on this issue, I don't want to block it :)

comment:6 Changed 5 years ago by Loic Dachary

I'm not sold on Docker myself, and I'm not sure we should promote it as if we were so confident in it.

I amended the commit to put Docker in second place and make it so it does not sound like MediaGoblin is endorsing Docker as the official way of doing things.

The Docker image is suggested for Docker users (which sounds more like "we also support Docker" and less like "we recommend Docker") after (instead of before) the step-by-step instructions.

https://notabug.org/dachary/mediagoblin-website/commit/321d0d4b5cc747612a1ed297ca90abeb881a8674

comment:7 Changed 5 years ago by ayleph

My immediate opinion is that this is something that would fit better on the wiki, perhaps in the hacking section. I'm concerned that pointing to a docker image would leave us in a bad position when that docker image becomes outdated.

I also noticed that the patch points to https://notabug.org/mediagoblin/mediagoblin-docker which doesn't exist. Was that a typo?

comment:8 Changed 5 years ago by Loic Dachary

@ayleph the image would have to be maintained, of course. I'm willing to do that and find a co-maintainer right away, just in case. If the image is maintained under the umbrella of mediagoblin, that will make this easier for me. Hence the proposal for https://notabug.org/mediagoblin/mediagoblin-docker instead of the one in my own namespace.

comment:9 Changed 5 years ago by Laura Arjona Reina

My proposal for this is:

  • Make a wiki page about 'easy deployments' including Docker, Sandstorm, and others
  • Link to it from https://wiki.mediagoblin.org/Deployment and from http://mediagoblin.readthedocs.org/*/siteadmin/deploying.html
  • Write a draft blog post about easy deployments, so we: (1) inform people about ways to run GNU MediaGoblin other than self-host or create account in a 3rd party instance. (2) thank the maintainers of those images. (3) encourage other people that have created images or other deployments to contact us or contribute to the 'easy deployments' wiki page, and (4) encourage/thank image maintainers to get involved in the community (subscribe to -devel mailing list, or participate in monthly meetings etc) so they get fresh news about roadmap, release dates etc, to ease the update/maintenace of their containerized images.

I can draft the blog post and the wiki pages, but not inmediately, maybe in a week or so.

comment:10 Changed 5 years ago by Laura Arjona Reina

Cc: Laura Arjona Reina added

comment:11 Changed 5 years ago by Christopher Allan Webber

That sounds appealing, larjona!

comment:12 Changed 5 years ago by Loic Dachary

I'm not confident in my ability to find a co-maintainer for a deployment method that is not directly recommended from the home page and I regretfully withdraw my proposal to maintain the image.

comment:13 Changed 5 years ago by Loic Dachary

Resolution: wontfix
Status: reviewclosed

comment:14 Changed 5 years ago by Loic Dachary

Resolution: wontfix
Status: closedaccepted

I had an idea this morning about how to recruit a co-maintainer. In a nutshell it's based on the hope that the Docker image can be leveraged for CI as well as demo. It's a long shot but, let's try that ;-)

comment:15 Changed 5 years ago by Loic Dachary

Owner: set to Loic Dachary
Status: acceptedin_progress

comment:16 Changed 5 years ago by Loic Dachary

Modified the proposed commit to the website with links to the EasyDeployment wiki page : https://notabug.org/dachary/mediagoblin-website/commit/08191d42f1bfade2ed42425c13aec1acc12963e6

It looks like a logged in user does not have permission to create a page on the wiki. Or am I missing something ?

comment:17 Changed 5 years ago by Christopher Allan Webber

loic, first of all, those changes to the website look great! I think linking to an EasyDeployment wiki page is a super great way to go.

Also, what's your username on the wiki... is it loic? You have to confirm your email to get certain rights, but I think also making new pages requires me to give you some privileges because of our suffering spam stuff. I can mark your email as confirmed and give you extra permissions.

Sorry that it's restricted as such; we've struggled with containing spam...

comment:18 Changed 5 years ago by Loic Dachary

@cwebber my user name is loic yes. Spammers are a plague indeed :-(

comment:19 Changed 5 years ago by Loic Dachary

comment:20 Changed 5 years ago by Christopher Allan Webber

Great, I merged the website branch and pushed! :)

loic, do you think that qualifies as "this branch should be closed"?

comment:21 Changed 5 years ago by Loic Dachary

Owner: Loic Dachary deleted
Resolution: fixed
Status: in_progressclosed

yes, let's close this ;-)

Note: See TracTickets for help on using tickets.