Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#5384 closed defect (duplicate)

Compiling error involving babel an localedata

Reported by: anongoblin Owned by:
Priority: major Milestone:
Component: programming Keywords: babel, babel-localedata, python-babel-localedata, locales, locale, i18n, make, compile, installation, install, stable
Cc: Parent Tickets:

Description

Probably related to #890 and not sure if to #1070

When compiling the last stable, Babel exits with this error message:

babel.core.UnknownLocaleError: unknown locale 'ia'

Workaround from http://pastebin.com/Cc37uigc (this links expires in 30 days):

This part of the instalation process of mediagoblin on debian jessie: http://mediagoblin.readthedocs.org/en/stable/siteadmin/deploying.html#install-mediagoblin-and-virtualenv

Fails for me at "make" with the following error message:

babel.core.UnknownLocaleError: unknown locale 'ia'


So I had to:

sudo apt-get install python-babel-localedata

# And then:

DIR_ORIGIN="/usr/share/python-babel-localedata/localedata/"
DIR_DESTINATION="/srv/mediagoblin.example.org/mediagoblin/lib/python2.7/site-packages/Babel-2.2.0-py2.7.egg/babel/locale-data/"
sudo ln ${DIR_ORIGIN}ia.dat ${DIR_DESTINATION}/
sudo chown mediagoblin:www-data ${DIR_DESTINATION}/ia.dat

Now it has compiled sucessfully.

Subtickets

Change History (2)

comment:1 Changed 5 years ago by Boris Bobrov

Resolution: duplicate
Status: newclosed

This is a very nice workaround, thank you. The issue is indeed related to #1070.

I am marking this bug as a duplicate and will post a link to it in #1070.

comment:2 Changed 5 years ago by anongoblin

Keywords: stable added

I forgot to mention, I was using the stable branch from savanah's git.

Note: See TracTickets for help on using tickets.