Opened 7 years ago

Closed 6 years ago

#5321 closed defect (fixed)

Use of deprecated frombytes when processing videos causes the task to fail

Reported by: anongoblin Owned by:
Priority: major Milestone:
Component: programming Keywords:
Cc: Parent Tickets:

Description

When transcoding a video using a recent version of PIL transcoding a video fails reproducible. The reason for this is an AttributeError: 'module' object has no attribute 'frombytes'gets raised, while a thumbnails is being created. This is because frombytes alias was deprecated in favor of fromstring.

The attached patch fixes this.

Subtickets

Attachments (1)

mediagoblin-video.patch (682 bytes) - added by anongoblin 7 years ago.

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by anongoblin

Attachment: mediagoblin-video.patch added

comment:1 Changed 6 years ago by berkerpeksag

Resolution: fixed
Status: newclosed

Thanks for the report and the patch. This has already been fixed in 5b8e0b2a63194d53da2ce434e867fc5eab1b60b4.

Note: See TracTickets for help on using tickets.