Opened 5 years ago

Closed 5 years ago

#5312 closed defect (duplicate)

Install Scripts Shebang on Freebsd

Reported by: Sebastian Hugentobler Owned by:
Priority: minor Milestone:
Component: programming Keywords: freebsd, installation
Cc: Parent Tickets:

Description

The following files, used in the installation process, fail on FreeBSD (10.1):

  • bootstrap.sh
  • devtools/update_extlib.sh
  • devtools/compile_translations.sh

Reason for this is the shebang line in all three:

#!/bin/bash

I replaced it with

#!/usr/bin/env sh

which works fine for me. Is there a specific reason for using bash here? If yes, could it be changed to use the env command? I can't symlink FreeBSDs default bash path (/usr/local/bin/bash) to /bin/bash from inside my jails as /bin is mounted readonly.

Subtickets

Change History (1)

comment:1 Changed 5 years ago by Loic Dachary

Resolution: duplicate
Status: newclosed

duplicate of #5315

Note: See TracTickets for help on using tickets.