Opened 7 years ago

Closed 7 years ago

#1074 closed enhancement (duplicate)

Upload audio to GNU MediaGoblin via the API

Reported by: Jessica Tallon Owned by:
Priority: minor Milestone:
Component: programming Keywords: api, federation
Cc: JanKusanagi Parent Tickets:

Description

Currently it's not possible to upload audio to GNU MediaGoblin via the API, this would be very useful. Activity Streams 1.0 does support audio they should look something like:

{
    "id": "https://gmg.site.tld/api/audio/someid",
    "objectType": "audio",
    "displayName": "Title of this audio",
    "embedCode": "<html><to><embed></embed></to></html>",
    "stream": {
        "url": "https://gmg.site.tld/path/to/audio.ogg",
    },
    "author": {
        "id": "acct:someone@gmg.site.tld",
        ...
    },
    "url": "https://gmg.site.tld/html/version/for/users/click"
}

Pump.io does look like it is able to store audio, they have the model which is here. This defines:

They also have all the usual properties possible on a object and can be interacted as such (liking, commenting, etc.)

Subtickets

Change History (2)

comment:1 Changed 7 years ago by JanKusanagi

Cc: JanKusanagi added

Pump.io is indeed able to store audio (and video, and any other kind of file as 'file' objectType).
Dianara can upload those, but they're not well presented in the webUI.

The stored objects contain all the relevant information (well, except for 'file' objects, which are missing proxyURLs), and a client which understands those kinds of attachments can download them.

comment:2 Changed 7 years ago by Jessica Tallon

Resolution: duplicate
Status: newclosed

This is a duplicate of #1073.

Note: See TracTickets for help on using tickets.