Opened 5 years ago

Closed 4 years ago

#5582 closed defect (fixed)

dbupdate fails with configobj.MissingInterpolationOption error

Reported by: anongoblin Owned by:
Priority: major Milestone:
Component: programming Keywords:
Cc: Parent Tickets:


I am trying to deploy mediagoblin on a Raspberry Pi 3B+ according to the instructions found on I've tried on both Raspbian Buster and Ubuntu MATE 18.04.2, but they both fail in the same place, as shown below.

mediagoblin@pi-mate:/srv/$ ./bin/gmg dbupdate
Traceback (most recent call last):
  File "./bin/gmg", line 11, in <module>
    load_entry_point('mediagoblin', 'console_scripts', 'gmg')()
  File "/srv/", line 148, in main_cli
  File "/srv/", line 235, in dbupdate
    global_config, app_config = setup_global_and_app_config(args.conf_file)
  File "/srv/", line 48, in setup_global_and_app_config
    global_config, validation_result = read_mediagoblin_config(config_path)
  File "/srv/", line 89, in read_mediagoblin_config
    mainconfig_defaults = copy.copy(config_spec.get("DEFAULT", {}))
  File "/srv/", line 96, in copy
    rv = reductor(4)
  File "/srv/", line 482, in __reduce__
  File "/srv/", line 557, in __getitem__
  File "/srv/", line 549, in _interpolate
  File "/srv/", line 352, in interpolate
  File "/srv/", line 330, in recursive_interpolate
  File "/srv/", line 417, in _parse_match
  File "/srv/", line 386, in _fetch
configobj.MissingInterpolationOption: missing option "here" in interpolation.

All of the steps leading up to that have executed successfully. I'm attaching the mediagoblin_local.ini file in case I missed something there, but I think everything is correct in it.

Attachments (1)

mediagoblin_local.ini (2.0 KB ) - added by anongoblin 5 years ago.
Configuration file

Download all attachments as: .zip

Change History (4)

by anongoblin, 5 years ago

Attachment: mediagoblin_local.ini added

Configuration file

comment:1 by Ben Sturmfels, 5 years ago

Thanks for taking the time to report this issue. I believe this issue is fixed in the "master" branch of the code. Would you mind testing this please?

In your /srv/ directory, please run git checkout master and then git pull. Let us know how you go.


Version 1, edited 5 years ago by Ben Sturmfels (previous) (next) (diff)

comment:2 by anongoblin, 5 years ago

Thanks! That fixed it.

comment:3 by Ben Sturmfels, 4 years ago

Resolution: fixed
Status: newclosed

Closing this ticket as resolved.

Note: See TracTickets for help on using tickets.