Opened 12 years ago

Closed 12 years ago

#412 closed defect (fixed)

Add instructions to install libjpeg-dev or equivalent to docs

Reported by: Christopher Allan Webber Owned by:
Priority: major Milestone:
Component: documentation Keywords: bitesized, docs
Cc: Parent Tickets:


People are constantly running into this irritation because a custom PIL gets built in their virtualenv:

IOError: decoder jpeg not available

Should be easy to do. Add both to the sphinx docs in the mediagoblin/ checkout and to the wiki Hacking Howto

Change History (5)

comment:1 by Dani Estevez, 12 years ago

I tried many things to fix this issue, being these the most important:

comment:2 by Jakob Kramer, 12 years ago

I think it is enough to say: “Make sure there is no custom PIL in your lib folder.” My problems have always been solved by that (and only that). I think we should replace the suggestion to install pillow with making sure that there is no custom PIL and then close the issue.

Version 0, edited 12 years ago by Jakob Kramer (next)

comment:3 by Christopher Allan Webber, 12 years ago

Component: component1documentation

comment:4 by ShawnRisk, 12 years ago

Owner: somebody removed
Status: newassigned

comment:5 by Jakob Kramer, 12 years ago

Resolution: fixed
Status: newclosed

Can be closed, because PIL is not being installed by anymore.

Note: See TracTickets for help on using tickets.