Custom Query (1173 matches)
Results (208 - 210 of 1173)
Ticket | Resolution | Summary | Owner | Reporter |
---|---|---|---|---|
#50 | FIXED | mongodb not scaling down: workaround and documentation | ||
Description |
mongodb needs 0.5 GB for a fresh install. Half of this goes to kombu. kombu could use redis or some other transport (see `#322 </issues/322>`_), so fixing `#322 </issues/322>`_ will help this issue too. mongodb database files contain a lot of NUL bytes. So one can easily use sparse files to save space on disk: :: # service mongodb stop # cd /var/lib/ # cp -a --sparse=always mongodb mongodb.new # mv mongodb mongodb.old # mv mongodb.new mongodb # service mongodb start # # TEST mongodb # rm -rf mongodb.old Maybe later versions of mongodb do this already internally. The above was needed on mongodb from debian/stable. Documenting the "make sparse" possibility will also help this issue. |
|||
#98 | FIXED | Create "setup" submodule | ||
Description |
The idea is to create a mediagoblin.setup submodule. This should contain code to get the app running. Things to move there (as examples): - celery\_setup/ -> setup/celery/ - util.get\_jinja\_loader (and friends?) - setup\_beaker, if/when it's coming - Maybe code from MediaGoblinApp.**init**() This issue is to track this idea. |
|||
#196 | FIXED | Change storage configuration in .ini | ||
Description |
The current configuration for the storage looks like this: :: [mediagoblin] publicstore_class = StorageBackend publicstore_base_dir = %(here)s/user_dev/media/public publicstore_base_url = /mgoblin_media/ publicstore_password = secret Instead I suggest an alternative configuration scheme: :: [storage:publicstore] class = StorageBackend base_dir = %(here)s/user_dev/media/public base_url = /mgoblin_media/ password = secret I implemented this on my dev/storage\_config branch. There is also an other config option with configobj, sub sub sections: :: [storage] [ [ publicstore ] ] base_dir = %(here)s/user_dev/media/public base_url = /mgoblin_media/ [ [ queuestore ] ] base_dir = %(here)s/user_dev/media/queue I don't know, if this one is "better". I would prefer the first one. |
Note:
See TracQuery
for help on using queries.